automake编译报错解决

张 佃栋 linux运维 2018-04-17 435 次浏览 , , 没有评论

automake编译报错解决

[root@localhost pcre-8.42]# automake
configure.ac:29: error: version mismatch.  This is Automake 1.13.4,
configure.ac:29: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:29: comes from Automake 1.15.1.  You should recreate
configure.ac:29: aclocal.m4 with aclocal and run automake again.

编译的时候报错,解决方法如下
第一步 :
autoscan
用 autoscan 产生一个 configure.in 的原型,执行autoscan 后会产生一个configure.scan 的文件,可以用它作为 configure.in文件的蓝本。
第二步:
aclocal
autoconf
执行 aclocal 和 autoconf ,分別会产生 aclocal.m4 及 configure 两个文件
然后执行:
automake –add-missing
最后执行:
./configure

本文出自张佃栋de博客,转载时请注明出处及相应链接。

本文永久链接: https://zhangdd.com/226.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注

回顶部