安装xtrabackup遇到missing requires of libmysqlclient.so.18()(64bit)报错解决办法

张 佃栋 linux运维, mysql 2018-06-05 545 次浏览 没有评论

安装xtrabackup的时候,到了安装perl-DBD-MySQL这一步的时候报错

Error: Package: perl-DBD-MySQL-4.023-6.el7.x86_64 (base)
Requires: libmysqlclient.so.18()(64bit)
Error: Package: perl-DBD-MySQL-4.023-6.el7.x86_64 (base)
Requires: libmysqlclient.so.18(libmysqlclient_18)(64bit)

错误提示安装依赖的库文件没有找到: libmysqlclient.so.18()(64bit)
解决方法是这样的:
安装mysql-community-libs-compat-5.7.18-1.el7.x86_64.rpm
安装了之后,再进行perl-DBD-MySQL 的安装,一切正常

本文出自张佃栋de博客,转载时请注明出处及相应链接。

本文永久链接: https://zhangdd.com/709.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Protected with IP Blacklist CloudIP Blacklist Cloud
回顶部